- Betroffene Versionen: ≤ 3.5
- Behoben in: 3.6
- CVE: CVE-2025-59586
- Veröffentlicht:
Korrigierte Version im Repository verfügbar: 3.6
composer require meteorgpl-plugin/penci-portfolio:^3.6
3 Versionen in diesem Repository sind betroffen: 3.5, 3.3, 3.1
Details
The Penci Portfolio plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 3.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Abhilfe: Update to version 3.6, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation