FlatNews <= 5.8 - Reflected Cross-Site Scripting
- Versiones afectadas: ≤ 5.8
- Corregido en: 6.2
- CVE: CVE-2025-32305
- Publicado:
Versión corregida disponible en el repositorio: 6.1
composer require meteorgpl-theme/flatnews:^6.1
Ninguna versión de este repositorio está afectada.
Detalles
The FlatNews theme for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 5.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Solución: Update to version 6.2, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation