Classima < 2.1.11 - Reflected Cross-Site Scripting
- Versions concernées: < 2.0.20
- Corrigé dans: 2.0.20
- CVE: CVE-2022-2654
- Publié:
Version corrigée disponible dans le dépôt : 2.2.0
composer require meteorgpl-plugin/classified-listing-pro:^2.2.0
Aucune version de ce dépôt n’est concernée.
Détails
The Classima theme for WordPress is vulnerable to Reflected Cross-site Scripting in versions up to 2.1.11 due to insufficient input sanitization and output escaping on the 'q' parameter. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This also affects the Classified Listing plugin before 2.2.14, Classified Listing Pro plugin before 2.0.20, Classified Listing Store & Membership plugin before 1.4.20 and Classima Core plugin before 1.10
Correction: Update to version 2.0.20, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation