- Versioni interessate: ≤ 10.3.0
- Corretto in: 10.3.1
- CVE: CVE-2025-64216
- Pubblicato:
Versione corretta disponibile nel repository: 10.5.2
composer require meteorgpl-theme/smart-mag:^10.5.2
1 versione di questo repository è interessata: 3.4.0
Dettagli
The SmartMag theme for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 10.3.0. This makes it possible for authenticated attackers, with contributor-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other "safe" file types can be uploaded and included.
Rimedio: Update to version 10.3.1, or a newer patched version
CWE-98: Improper Control of Filename for Include/Require Statement in PHP Program