Each version is cleaned, compared against the vendor’s license code and scanned before it is committed. A version that does not pass is not published. Last scan .
5 known vulnerabilities affect 2.0.16, the latest version in the repository.
See known vulnerabilities
Published versions1
Files scanned135
Findings reviewed1
Versions held back0
Held back: archives of this plugin that did not pass the automatic checks and are not published. Findings reviewed: matches of the rules that were checked and resolved before publication.
Reporting a vulnerability. Security problems in the plugin’s own code belong to the vendor, CleverSoft; report them there. Problems with a package as this repository distributes it — a file that should not be there, a scan that missed something — go to packages@meteorgpl.com, and are answered within 48 hours.
What happens on a finding. The affected versions are withdrawn from the repository, watchers of the package are notified, and a corrected version is published when one passes every check.
Rights holders. The takedown policy describes how a package is removed.
Known vulnerabilities
Public vulnerability reports for Clever Addons for Elementor, the versions they affect and the version in this repository that fixes them. Watchers and accounts known to run an affected version are alerted.
The Clever Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Remediation: No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
CWE-79: Improper Neutralization of Input During Web Page Generation
The Clever Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.2.1 via the getTemplateContent function in src/widgets/class-clever-widget-base.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft template data.
Remediation: No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The vendor fixed it in 2.2.1; that version is not in the repository yet.
1 version in this repository is affected: 2.0.16
Details
The Clever Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Scroll to widget in versions up to, and including, 2.2.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Remediation: Update to version 2.2.1, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation
The vendor fixed it in 2.2.0; that version is not in the repository yet.
1 version in this repository is affected: 2.0.16
Details
The Clever Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the CAFE Icon, CAFE Team Member, and CAFE Slider widgets in all versions up to, and including, 2.1.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Remediation: Update to version 2.2.0, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation
The vendor fixed it in 2.1.0; that version is not in the repository yet.
1 version in this repository is affected: 2.0.16
Details
The “Clever Addons for Elementor” WordPress Plugin before 2.1.0 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Remediation: Update to version 2.1.0, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation
Copyright 2012-2026 Defiant Inc.. Defiant hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute this software vulnerability information. Any copy of the software vulnerability information you make for such purposes is authorized provided that you include a hyperlink to this vulnerability record and reproduce Defiant's copyright designation and this license in any such copy. https://www.wordfence.com/wordfence-intelligence-terms-and-conditions/
Copyright 1999-2026 The MITRE Corporation. CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE®). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy. https://www.cve.org/Legal/TermsOfUse