Each version is cleaned, compared against the vendor’s license code and scanned before it is committed. A version that does not pass is not published. Last scan .
A known vulnerability affects 4.13.11, the latest version in the repository.
See known vulnerabilities
Published versions19
Files scanned14K
Findings reviewed264
Versions held back0
Held back: archives of this theme that did not pass the automatic checks and are not published. Findings reviewed: matches of the rules that were checked and resolved before publication.
Reporting a vulnerability. Security problems in the theme’s own code belong to the vendor, Brainstorm Force; report them there. Problems with a package as this repository distributes it — a file that should not be there, a scan that missed something — go to packages@meteorgpl.com, and are answered within 48 hours.
What happens on a finding. The affected versions are withdrawn from the repository, watchers of the package are notified, and a corrected version is published when one passes every check.
Rights holders. The takedown policy describes how a package is removed.
Known vulnerabilities
Public vulnerability reports for Astra, the versions they affect and the version in this repository that fixes them. Watchers and accounts known to run an affected version are alerted.
The vendor fixed it in 4.14.0; that version is not in the repository yet.
19 versions in this repository are affected: 4.13.11, 4.13.0, 4.11.14, 4.11.3, 4.11.0, 4.8.10, 4.8.8, 4.8.7, 4.8.6, 4.8.4, 4.7.2, 4.7.1 …
Details
The Astra theme for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.13.12. This is due to missing sanitize_callback on the astra-color-palettes and astra-settings[global-color-palette] customizer controls, combined with insufficient CSS value sanitization that did not strip declaration-breaking characters such as semicolons and braces. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary CSS into pages by supplying crafted color values through the global color palette customizer setting, breaking out of CSS declarations and altering page appearance or injecting malicious style rules.
Remediation: Update to version 4.14.0, or a newer patched version
CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component
17 versions in this repository are affected: 4.11.14, 4.11.3, 4.11.0, 4.8.10, 4.8.8, 4.8.7, 4.8.6, 4.8.4, 4.7.2, 4.7.1, 4.7.0, 4.6.15 …
Details
The Astra theme for WordPress is vulnerable to Stored Cross-Site Scripting via the `ast-page-background-meta` and `ast-content-background-meta` post meta fields in all versions up to, and including, 4.12.3. This is due to insufficient input sanitization on meta registration and missing output escaping in the `astra_get_responsive_background_obj()` function for four CSS-context sub-properties (`background-color`, `background-image`, `overlay-color`, `overlay-gradient`). This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Remediation: Update to version 4.12.4, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation
5 versions in this repository are affected: 4.6.7, 4.6.5, 4.6.1, 4.5.2, 4.5.0
Details
The Astra theme for WordPress is vulnerable to Stored Cross-Site Scripting via a user's display name in all versions up to, and including, 4.6.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Remediation: Update to version 4.6.9, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation
3 versions in this repository are affected: 4.6.1, 4.5.2, 4.5.0
Details
The Astra theme for WordPress is vulnerable to Stored Cross-Site Scripting via the theme header and footer content in all versions up to, and including, 4.6.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with editor-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Remediation: Update to version 4.6.5, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation
Copyright 2012-2026 Defiant Inc.. Defiant hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute this software vulnerability information. Any copy of the software vulnerability information you make for such purposes is authorized provided that you include a hyperlink to this vulnerability record and reproduce Defiant's copyright designation and this license in any such copy. https://www.wordfence.com/wordfence-intelligence-terms-and-conditions/
Copyright 1999-2026 The MITRE Corporation. CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE®). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy. https://www.cve.org/Legal/TermsOfUse