- Affected versions: ≤ 2.4.21
- Fixed in: 2.4.22
- CVE: CVE-2026-39443
- Published:
Fixed version available in the repository: 2.4.22
composer require meteorgpl-theme/emallshop:^2.4.22
7 versions in this repository are affected: 2.4.14, 2.4.13, 2.4.11, 2.4.10, 2.4.9, 2.4.7, 2.4.5
Details
The EmallShop theme for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.4.21 via deserialization of untrusted input. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Remediation: Update to version 2.4.22, or a newer patched version
CWE-502: Deserialization of Untrusted Data