- Versioni interessate: < 3.1.4
- Corretto in: 3.1.4
- CVE: CVE-2023-49187
- Pubblicato:
Versione corretta disponibile nel repository: 3.9.7
composer require meteorgpl-theme/adifier:^3.9.7
Nessuna versione di questo repository è interessata.
Dettagli
The Adifier (Premium Theme) theme for WordPress is vulnerable to Reflected Cross-Site Scripting via an unknown parameter in versions up to, and including, 3.9.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Rimedio: Update to version 3.1.4, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation