- Affected versions: < 3.1.4
- Fixed in: 3.1.4
- CVE: CVE-2023-49187
- Published:
Fixed version available in the repository: 3.9.7
composer require meteorgpl-theme/adifier:^3.9.7
No version in this repository is affected.
Details
The Adifier (Premium Theme) theme for WordPress is vulnerable to Reflected Cross-Site Scripting via an unknown parameter in versions up to, and including, 3.9.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Remediation: Update to version 3.1.4, or a newer patched version
CWE-79: Improper Neutralization of Input During Web Page Generation